Solution for LayerSlider problems

Support Forums Support Forums Goodnex WordPress Theme Solution for LayerSlider problems

This topic contains 1 reply, has 2 voices, and was last updated by  jack 3 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #16224

    Exclusive-IT
    Participant
    Exclusive-IT themes
    Theme Name Buyer License Supported Until
    Goodnex | Creative Design Agency Responsive WordPress Theme Exclusive-IT Regular License 26/12/2017

    Hi guys,

    Today I installed this theme and noticed, after importing the demo data, that the homepage wasn’t working.

    After enabling WP_DEBUG in wp-config.php I noticed there were fatal errors in the LayerSlider plugin which seems not to be updated for the latest version of PHP.

    Since the creator is not releasing an update so far, I decided to fix it myself until a new update is released. Just edit the following two files:

    public_html/wp-content/plugins/LayerSlider/includes/slider_markup_html.php
    paste this code in the above file: https://gist.github.com/anonymous/2c1059a8049cc3d5a7fe898da3046fcf

    public_html/wp-content/plugins/LayerSlider/includes/slider_markup_init.php
    paste this code in the above file: https://gist.github.com/anonymous/7f7f44767e7981fc422798e1ae639b84

    The problem with these is that the code is trying to add elements to an array variable that is declared as a string, or at least not explicitly as an array.. with the code linked above it is all fixed and working as it should.

    Just thought I’d share this.

    #16226

    jack
    Moderator

    Hi there,

    thank you for sharing your solution, we greatly appreciate it.

    Regards,
    Jack

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.