php 5.4 incompatibility ?

Support Forums Support Forums Wedding WordPress Theme php 5.4 incompatibility ?

This topic contains 3 replies, has 3 voices, and was last updated by  jack 3 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #7376

    laetitiamattei
    Participant

    Hi

    I’m getting an error at the first install of the theme.

    The php version is 5.4.6-1

    and the error is

    Fatal error: ‘continue’ operator with non-constant operand is no longer supported in /flex/domain/laetitiafrederic.com/site/www/wp-content/themes/weddingalbum/admin/registry/slide.php on line 112

    Thanx

    #7382

    jack
    Moderator

    Hello laetitiamattei,

    In order to find the solution on fixing this issue we would need to check your website. Please submit a ticket in our support ticket system with admin panel and FTP access details provided. We will check your website and will help you resolving this issue.

    Best regards,
    Jack

    #8944

    marketermatt
    Participant

    I seem to have resolved this issue by changing the file in question from this
    if( empty($value) ) {
    continue delete_post_meta($post_id, $key); // удаляем поле если значение пустое

    to this
    if( empty($value) ) {
    delete_post_meta($post_id, $key); // удаляем поле если значение пустое
    continue;
    }

    #8965

    jack
    Moderator

    Hello Marketermatt,

    That’s great you have managed to sorted it out on your own. Thanks for the updates and thank you for sharing your solution here.

    Best regards,
    Jack

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.