CarDealer WP theme – internal error appears when uploading images

We have recently received couple reports regarding the internal error that appears upon uploading car images. In all cases that we reviewed this issue appears due to the  server configuration and usually because of not having the proper amount of memory allocated to Apache/PHP.

If anyone has faced this same problem on your website, please try verifying that you have enough (64MB+) server memory allocated to Apache/PHP in your server configuration settings. You can also add this to your wp-config.php file: define('WP_MEMORY_LIMIT', '64MB');

If the above solution does not work the then issue in your .htaccess file, which might be even not be presented in your WP root, so please check on it first.

If you have  .htaccess file then try adding this tweaks one by one to your .htaccess file:

AddType x-mapp-php5 .php

mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

If you're using Access Control based on Authentication on your Webserver (often known as htpasswd, Basic Authentiaction, password protected directory or similar), WordPress is not able to handle it for Flash Uploader, Cron and XMLRPC. Related files need to be excluded to work. Keep in mind that this might break your security considerations.

# Exclude the file upload and WP CRON scripts from authentication
<FilesMatch "(async-upload\.php|wp-cron\.php|xmlrpc\.php)$">
    Satisfy Any
    Order allow,deny
    Allow from all
    Deny from none
</FilesMatch>

One final note: if using a lesser version of PHP 5.3.X you can try disabling PHP Safe Mode.

That’s it, and if you still running this issue on your website then please submit a ticket ad we will definitely help you getting it solved.

Leave a Reply